Welcome to airkyon.com , enjoy your stay!

WordPressが死亡(原因はプラグインのBad Behavior)

2012年10月12日 - Posted by reibo - Inside [Blog] Word Press   このエントリをはてなブックマークに追加このエントリをYahoo!ブックマークに追加
12 10月.

 WordPressでいつものように、何も考えずプラグインを更新すると…。

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ‘)’ in /***/***/wp-content/plugins/bad-behavior/bad-behavior/blacklist.inc.php on line 95

 とのエラーが出て、WordPress自体が表示不可能(設定画面にログインもできない)な状態に。。。
 複数のプラグインを同時に更新したので「エ? エ?」だったものの、エラーメッセージを見るとプラグイン:Bad Behaviorに問題があるらしい。
 ログインできない状態=WordPress上からは何もできないので、ftpで該当するblacklist.inc.phpをダウンロードし、調べてみる。
 問題の95行目に記載されているのは…。

“Perman Surfer”, // old and very broken harvester

 プログラム部分じゃないし? これでエラーだと言われても困る…。
 対処方法が不明なので、とりあえずftpからBad Behaviorを削除。これで表示、ログインとも可能になりました。
 WordPressのバージョンは最新の3.4.2で、Bad Behaviorの該当ページには「Compatible up to: 3.4.2」とある。つまり、WordPressのバージョンが問題なわけではない。
 んー?
 検索してみてもそれらしき情報は見つからず、お手上げ。
 (どなたかわかる方がいらしたら教えて下さい)
 まぁ、なければないで支障はないとも思われるプラグインなので、当面は削除したままにしておきます。

  Check  拍手する

コメントを投稿する

CAPTCHA


*